If geeks love it, we’re on it

Howdy, Stranger!

You found the friendliest gaming & tech geeks around. Say hello!

Display monitors going to sleep

CrazyJoeCrazyJoe Winter Springs, FL Icrontian

So I built a new PC with Christmas money that I had and everything has been going great. However within the last few weeks or so I've been having a problem pop up a couple of times. Sometimes my monitors will go to sleep and I can't wake them up without resetting my PC. The specs of my PC Build are below:

Asus Z170 Pro Gaming Motherboard
Intel i5 6600K CPU
2 x 8GB DD4
AMD RX480 8GB GPU
RMx 550X Power Supply

In my research there were a few places that said it could be due to lack of power but all the online calculators said that my PC should be running at around 350W on my setup and that is pretty much what my battery backup is showing as well. I've yet to see a peak load hit over 325W and that includes the two monitors that I'm running, which obviously don't run off my PSU in my PC.

Any ideas on what would cause this? I'm stumped. It doesn't happen often (maybe 3-4 times in the past two weeks) but it's happening enough to be annoying.

Comments

  • ThraxThrax Professional Shill, Watch Slut, Mumble Hivemind Drone Austin, TX Icrontian

    What is your monitor and how is it connected to the GPU?

  • CrazyJoeCrazyJoe Winter Springs, FL Icrontian
    edited 26 Feb
  • ThraxThrax Professional Shill, Watch Slut, Mumble Hivemind Drone Austin, TX Icrontian

    What GPU driver and OS?

  • edcentricedcentric near Milwaukee, Wisconsin Icrontian

    Have you tried using other monitor inputs?
    I have a pair of HP monitors and when I used DVI one of them wouldn't so into standby, not that they are both on HDMI it works fine.

  • CrazyJoeCrazyJoe Winter Springs, FL Icrontian

    I had the Radeon 17.2.1 driver installed but it was causing a flickering grass texture problem in ESO so I rolled back to 16.12.2. I am using Windows 10 64 bit.

  • ThraxThrax Professional Shill, Watch Slut, Mumble Hivemind Drone Austin, TX Icrontian

    Is there any rhyme or reason to when the blackouts happen? 3D only? Desktop?

  • CrazyJoeCrazyJoe Winter Springs, FL Icrontian

    Nope. One time I was just surfing the net and watching Hulu, one time playing Elder Scrolls Online. Nothing specific I can pinpoint.

  • ThraxThrax Professional Shill, Watch Slut, Mumble Hivemind Drone Austin, TX Icrontian

    Have you tried other monitor inputs or cables? When you rolled back your driver, how did you do it? What is your Windows power plan set to?

  • CrazyJoeCrazyJoe Winter Springs, FL Icrontian

    I have not tried other cables. I don't have any other DVI cables, nor other monitors that have DVI connections, the only other one I have is my wife's and it is older and uses VGA. When I rolled back the driver I uninstalled the driver from Control Panel and ran the old setup file I still had from 16.12. Power plan is set to Balanced. Turn off screen after 10 minutes, PC goes to sleep Never.

    On a side note, any ideas on what would cause the texture flickering with the latest Radeon driver?

  • ThraxThrax Professional Shill, Watch Slut, Mumble Hivemind Drone Austin, TX Icrontian

    I would use the AMD Clean Uninstall utility and give it another go. Alternatively, the application "DDU" is very nice.

    It's impossible to know who's at fault in the texture filtering. Could be a tweak in the driver, could be something in the game. There's a built-in bug reporter in our driver now! Make sure to let our team know so they can fix it. :)

  • primesuspectprimesuspect Beepin n' Boopin Detroit, MI Icrontian

    You know Joe this is what I think is happening to me too. I keep saying my "GPU is rebooting" but really what is happening is both monitors are shutting off and then waking up after about 5 seconds. After they wake back up everything freezes for a second while the computer "catches up" with whatever it was rendering/doing and then it goes back to normal. This happens more often with increased activity.... i.e. if I have a browser window open with three tabs and then click on another window, all while playing a game, this will happen.

    I'm beginning to realize that this all happened when I went to the Radeon 17.x series drivers. I did do a clean uninstall when I upgraded but I think I'm going to do a full uninstall and reinstall of the 16.x series.

  • CrazyJoeCrazyJoe Winter Springs, FL Icrontian

    Yep. From what I can see on both the AMD/ESO sites it has been reported and lots of people are having the same issue. I tried clean uninstall and I have the same issue. Back to 16.x series drivers for me too.

  • CrazyJoeCrazyJoe Winter Springs, FL Icrontian

    Still have the same display going to sleep problem intermittently. No particular rhyme or reason why, it's frustrating.

  • ThraxThrax Professional Shill, Watch Slut, Mumble Hivemind Drone Austin, TX Icrontian

    Had a thought just now: try setting your Windows power profile to High Performance.

    CB
  • ThraxThrax Professional Shill, Watch Slut, Mumble Hivemind Drone Austin, TX Icrontian
  • CrazyJoeCrazyJoe Winter Springs, FL Icrontian
    edited 7 Mar

    Thanks for the heads up but it did not fix the issue in ESO.

  • primesuspectprimesuspect Beepin n' Boopin Detroit, MI Icrontian

    Hey @CrazyJoe is this still happening? I'm beginning to think several of us are having this issue. I had it happen on my old system, I had it happen once on my brand-new system, and now @UPSLynx is having a similar issue. Any insight?

  • SnarkasmSnarkasm Madison, WI Icrontian

    Similar but related, maybe - is there any fix to the issue where DisplayPort-linked monitors disappear from Windows when in sleep? Every time I come back to my computer, all my windows are shoved onto the primary monitor. :(

  • CrazyJoeCrazyJoe Winter Springs, FL Icrontian

    @primesuspect said:
    Hey @CrazyJoe is this still happening? I'm beginning to think several of us are having this issue. I had it happen on my old system, I had it happen once on my brand-new system, and now @UPSLynx is having a similar issue. Any insight?

    It hasn't happened since I rolled back to the 16.12 driver. Also that fixed the flickering grass issue in ESO as well. There are a few threads on the AMD support forums, but no fix as of yet.

  • ThraxThrax Professional Shill, Watch Slut, Mumble Hivemind Drone Austin, TX Icrontian
    edited 17 Mar

    @Snarkasm said:
    Similar but related, maybe - is there any fix to the issue where DisplayPort-linked monitors disappear from Windows when in sleep? Every time I come back to my computer, all my windows are shoved onto the primary monitor. :(

    No, this is by design. DisplayPort is intended to be hotplugged, and its designers did not want to orphan windows off the visivle surface when a DP monitor was removed. I wish Windows could override this.

    //Edit: this https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/disabling-monitor-auto-detection-in-windows-10/e4f6bbc3-b45f-4880-8b06-3e339d62ac59

  • SnarkasmSnarkasm Madison, WI Icrontian

    @Thrax said:

    @Snarkasm said:
    Similar but related, maybe - is there any fix to the issue where DisplayPort-linked monitors disappear from Windows when in sleep? Every time I come back to my computer, all my windows are shoved onto the primary monitor. :(

    No, this is by design. DisplayPort is intended to be hotplugged, and its designers did not want to orphan windows off the visivle surface when a DP monitor was removed. I wish Windows could override this.

    //Edit: this https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/disabling-monitor-auto-detection-in-windows-10/e4f6bbc3-b45f-4880-8b06-3e339d62ac59

    :(

  • RyderRyder Kalamazoo, Mi Icrontian

    @Snarkasm do you mean the monitor goes to sleep or the computer?

  • SnarkasmSnarkasm Madison, WI Icrontian

    Computer never sleeps. My workflow is lock PC, turn off monitors. When I come back and turn them back on and sign in, all my windows have moved to the primary monitor.

  • RyderRyder Kalamazoo, Mi Icrontian

    Ok, you power them off. Letting them sleep is not an option? I do almost the same and I never lose my icons.

  • SnarkasmSnarkasm Madison, WI Icrontian

    @Ryder said:
    Ok, you power them off. Letting them sleep is not an option? I do almost the same and I never lose my icons.

    It could be, but I prefer the security of turning them off. And just to make sure we're talking about the same thing, my icons aren't moving, all my windows are. If I have TS and a browser on screen 2, following my workflow and then returning has them all lumped on top of each other on screen 1 like screen 2 just disappeared (which, to the OS, it seems it did).

  • ThraxThrax Professional Shill, Watch Slut, Mumble Hivemind Drone Austin, TX Icrontian

    There's no way to override if you're just turning the displays off.

  • CrazyJoeCrazyJoe Winter Springs, FL Icrontian

    In related news, it looks like the 17.4.2 update finally fixed the flickering grass on ESO.

    ThraxZanthian
Sign In or Register to comment.