If geeks love it, we’re on it

Howdy, Stranger!

You found the friendliest gaming & tech geeks around. Say hello!

Quotation Mark (Key) Problem

vanagon40vanagon40 Indiana Member
edited Jul 2011 in Science & Tech
My quotation key (") is not working right. When I press the key [Shift '/"], I do not immediately get the quotation mark. To make the quotation mark appear, I must type a space after the quotation, but the space does not appear. In other words, to type:
John said "goodby" and left
I must type: J, o, h, h, [space], s, a, i, d, [space], [Shift '/"], [Space], g, o, o, d, b, y, [Shift '/"], [Space], [Space], a, n, . . .

This is a keyboard problem, not a word processor problem. I have this problem in all programs--Microsoft Word, Corel, AOL, IE, Mozilla, etc.

Here is my history:

I've got an old Gateway (1998 or 1999), P3, Windows 98. When the "computer guy" at work installed a new networking system and virus protection system, he told me my computer was so messed up it would not run McAfee virus protection. I suspect I was overloaded with Spyware, but this was before I knew anything about Spyware. He suggested I dump my entire system and reload Windows 98. I had all the original discs, so I followed his advice and reloaded Windows. The "computer guy" then hooked my computer up to the network and installed McAfee. This is when my quote key problem started. Everything now works AOK on the computer except the quote key.

I am not sure when exactly this problem started, but I did not have this problem before I reloaded Windows. It may have started immediately after I reloaded Windows, or maybe after I loaded the Gateway keyboard driver, updated Windows, etc.

I am pretty sure my computer is completely clean of viruses, spyware, etc., because shortly after reloading Windows (and after the quote key problem became apparent), I got infected with the CoolWebSearch about:blank and I spent a week trying to get rid of it. I now have Ad-Aware, Spybot, etc., and my systems shows completely clean (and my HJT log is clean).

I did attempt to adjust "smart quote" in my word processor, but that did not change anything (and again, this problem is in all programs).

Has anyone ever heard of this? I guess I will start by changing keyboards and loading a new keyboard driver, but I thought if someone else had heard of this, there might be a simple answer.

As an aside, for the last year, I have horizontal shadows across my computer screen. This is NOT a monitor problem, as I swapped monitors with the same result. The horizontal shadows appeared long before I reloaded Windows (and long before I got the quote key problem). The horizontal shadows did not change when I reloaded Windows.

Comments

  • ketoketo Occupied. Or is it preoccupied? Icrontian
    edited Jun 2004
    I'm.afraid.I.can't.answer.your.problem.but.I.had.a.friend.who's.spacebar.broke.and.he.learned.to.use.periods.instead.of.spaces.between.words...It.was.annoying.as.hell.but.boy.did.he.get.good.and.fast.at.it!
  • primesuspectprimesuspect Beepin n' Boopin Detroit, MI Icrontian
    edited Jun 2004
    Keyboards are super cheap, just replace it. The shadows on the monitor sound like a dying video card.
  • GuyuteGuyute Gamehenge
    edited Jun 2004
    It might be worth checking your character map. If it is right in the map, you could maybe just re-assign the keystroke...

    Start>Programs>Accessories>System Tools>Character map
  • botheredbothered Manchester UK
    edited Jun 2004
    Keyboards are super cheap, just replace it. The shadows on the monitor sound like a dying video card.

    Prime, what about memtest?
  • vanagon40vanagon40 Indiana Member
    edited Jun 2004
    I swapped out my keyboard, with no change. The device manager shows "Standard 101/102-Key or Microsoft Natural Keyboard"

    As I have the Gateway multifunction keyboard, I am also running Gwhotkey. However, I uninstalled Gwhotkey and still had the problem, and now that I have reloaded it (new download) there is no change.

    This might be something I have to learn to live with???

    And amazing but true Keto, I also had a keyboard with a broken space key and used periods between words. It made internet searching very difficult as could use only single word search terms (but I think the modem was about 2 baud, so I wasn't going anywhere fast anyway).
  • Straight_ManStraight_Man Geeky, in my own way Naples, FL Icrontian
    edited Jun 2004
    Guyute wrote:
    It might be worth checking your character map. If it is right in the map, you could maybe just re-assign the keystroke...

    Start>Programs>Accessories>System Tools>Character map

    Check the country you are using, this is an international keyboard most probably, or the country code for default charmap is set wrong. The sequence you are using tells that the apps are set to ASCII and the keyboard is international, and the charmap is set to ASCII\US or IBM. On my keyboard, " is above and is a shifted '. key resides to left of Enter\Return, keyboard is an IBM Pro-grade keyboard. In this situation, try this:

    Try using a shifted 2 and see if you get a " in programs.... IF so, this is a German layout IMU-equivalence in keyboard ROM, international character set keyboard. That is the keystroke layout-based workaround from my Keytronics Eurotech(multilingually switchable german\english (dual-ROMMED)) keyboard, and THAT keyboard can be switched to use ASCII also with a keystroke sequence on keyboard itself. IBM layout is recognized by XP, 98, 98 SE as default as a standard charmap keyboard by default. NOTE, a Dvorak keyboard will have other issues with keystroke remaps against a standard driver in Windows. To make Windows multilingual, you use one language per user ID, for best results. EACH UID in XP can call a different IMU and country code if you restart computer, and this part is true for 98 upward.

    Getting a Germanic\European regional distrib of XP can cause this, the default IMU is then synced to European keyboard mappings by default in the distrib. XP is being regionalized some, and OEMs can regionalize defaults as to IMU modules used and default driver to IMU mappings. Microsoft, Keytronics, and European-regionalized IBM keyboards al;so exist.

    If the thread starter will tell me what Windows is in place and where as to region of world computer came from, I might be able to tell him how to set up for a Windows-UID specifc fix for this using an IMU replacement gotten from Microsoft's download or Technet site.

    Which Windows is being used, or is this Xandros Desktop Pro 2.0???
  • MancabusMancabus Charlottesville, VA
    edited Jun 2004
    Get your hands on a USB Keyboard, then see what it gives you as a result. You may have a bad PS2 port.

    You could also try plugging the keyboard into the mouse PS2 port and see what happens.
  • vanagon40vanagon40 Indiana Member
    edited Jun 2004
    John_D,

    I think maybe you are on the right track. Shift "2" gives me this: @. As you suggested, the quotation mark is a shift apostrophe--the key to immediate left of "enter" . As I type this, I also note that I must put a [space] after the apostrophe to get it to appear as well.

    When I look at the character map, I note that the top row is as follows:

    [space], !, ", #, $, %, &, ', (, ), *, +, . . . . .

    This symbol:
    ^ [shift 6]
    must also be followed by a space to appear.

    Note that if I type
    [shift '/"], [space], e
    I get
    "e

    but if I type
    [shift '/"], e
    I get
    ë

    very baffling

    In response to a couple of questions:

    I'm in the middle of the US (Indiana), got the computer from Gateway, and never had this problem 'till I restored my hard drive.

    I swapped keyboards ports with no change.

    I'm using a Gateway keyboard, however, a different US keyboard produces the same result.

    OS = Windows 98
  • SpinnerSpinner Birmingham, UK
    edited Jun 2004
    vanagon45 wrote:
    John_D,

    I think maybe you are on the right track. Shift "2" gives me this: @. As you suggested, the quotation mark is a shift apostrophe--the key to immediate left of "enter" . As I type this, I also note that I must put a [space] after the apostrophe to get it to appear as well.

    When I look at the character map, I note that the top row is as follows:

    [space], !, ", #, $, %, &, ', (, ), *, +, . . . . .

    This symbol: must also be followed by a space to appear.

    Note that if I type
    I get

    but if I type
    I get

    very baffling

    In response to a couple of questions:

    I'm in the middle of the US (Indiana), got the computer from Gateway, and never had this problem 'till I restored my hard drive.

    I swapped keyboards ports with no change.

    I'm using a Gateway keyboard, however, a different US keyboard produces the same result.

    OS = Windows 98
    As John_D I think suggested, I'm pretty sure it's a Regional and Language settings problem. I get the old 'Shift - 2' = @ instead of " frequently when I haven't set my location and language settings probably. I imagine it's to do with matching some of those settings with the origins of your keyboard. But I'm no expert on this subject. Follow John_D's lead and he'll have you sorted in no time.

    Cheers
  • Straight_ManStraight_Man Geeky, in my own way Naples, FL Icrontian
    edited Jun 2004
    Spinner wrote:
    As John_D I think suggested, I'm pretty sure it's a Regional and Language settings problem. I get the old 'Shift - 2' = @ instead of " frequently when I haven't set my location and language settings probably. I imagine it's to do with matching some of those settings with the origins of your keyboard. But I'm no expert on this subject. Follow John_D's lead and he'll have you sorted in no time.

    Cheers

    Is this Gateway under warranty???? If yes, ask Gateway tech support how to set your country settings in registry directly-- not just in GUI, but as to registry entries.

    Second, check your TIme Zone, 98 syncs IMU to time Zone by default. If it is set to Germany, you might have a very weird keyboard map in place.

    Also, any wild chance the recovery CD was intended for out of country??? Those CDs come prescripted (essentially they run a scripted OEM install), and you could have gotten a scripted install telling the installer to set up for an international install. If it is not a Gateway CD you used, Gateway might have had an intenrational mfr make the keyboard they use, and they might have used a non-standard keymap themselves by default.

    To see if this is keyboard keymap issue, one of two things can be done in 98:

    In the Control Panel there might be a Keyboard icon. If so, try double-clicking it, see if there is a properties tab on the resulting dialog. If NOT, cancel out of it, then right click the keyboard icon in Control Panel. What you need to change is the international setting, ideally you want Code Page 1252 or 1033 (1033 is best for US only, 1252 for English supporting Canadian boxes, but that will also work for US boxes OK). Look for a listing of two-letter abbreviations or country names. If names, you want United States highlighted. If codes, use EN(will get you code page 1252) or US or US-EN(will get you code page 1033 or 1252) if that shows up. 98 might ask for the Windows install CD to get this change working, probably not. Restart computer to make sure it keeps this setting, after clicking Apply if that button exists, then OK.

    If that is still not fixing the problem, then we are going to have fun.... Microsoft has buried the things I wanted to look up quickly, but tell me if that does not fix and I will dig into some older reference stuff-- like the Windows 98 Resource Kit I still have around in book and CD format.
  • vanagon40vanagon40 Indiana Member
    edited Jun 2004
    Sorry for the delay in reply, but I did not realize there was a response.

    EDIT: Now I see why I missed the response, I did not notice I got MOVED to Windows.

    Your solution worked John.

    The keyboard setting was for US-International. I changed it to US-101.

    Now I have "no problems." [and that was typed correctly].

    Thanks everyone for your assistance, especially John_D

    Everyone is so helpful here--I love this place.

    BTW, this computer has not been under warranty since 2000.
  • edited May 2010
    IMay not be exactly the same, but I had a similar type of problem over and over again. I was having to shut down programs and start them again. I knew I'd just made a typo somewhere that had turned this on but I couldn't turn it off - FINALLY I found someone who said - just hit CTRL on the LEFT and SHIFT on the RIGHT. Bingo. I can turn that on and off now. È or " É or ?. It works!
  • edited Jul 2011
    I'm only signing up / replying because I think I solved it, at least for myself.

    I left clicked my language bar and noticed I was set to "United States - International", I would change it to "US" but it changed back to the "United States - International" setting as soon as I typed something. I right clicked the language bar and unselected "Auto Adjust".

    Fixed.

    Took me 6 months to get around to doing that, FML. :rockon:

    GL
  • Press Control and Shift at the same time. Fixes it instantly.
  • KwitkoKwitko Sheriff of Banning (Retired) By the thing near the stuff Icrontian
    I think you're a little late.
    troll
Sign In or Register to comment.

The 5¢ Tour