If geeks love it, we’re on it

Howdy, Stranger!

You found the friendliest gaming & tech geeks around. Say hello!

Icrontic Expo 2014: The gaming & general geekery event you don't want to miss. Read about what's new this year and then buy tickets here.

ping is not recognized as an internal or external command

edited Feb 2009 in Technology
Hey everyone, I'm having an odd one ive not run into before on my laptop. I know reinstalling is always an option I'm just thinking this has to be fixable via other ways.

These all occur at command line of course:

'ping' is not recognized as an internal or external command
'defrag' is not recognized as an internal or external command
'ipconfig' is not recognized as an internal or external command

I wonder what I did to make these commands not recognized. Ideas?

Comments

  • Park_7677Park_7677 Missouri Member
    edited Oct 2005
    Probably the .exes for the commands are deleted. They should be in \Windows\System32 (ping.exe, defrag.exe, ipconfig.exe). You can repair the installation or just simply find a computer with the same OS and copy the few you need.

    Good luck. :thumbsup:
  • edited Oct 2005
    The files themselves exist in system 32, I should have mentioned that.
  • Park_7677Park_7677 Missouri Member
    edited Oct 2005
    Tange1 said:
    The files themselves exist in system 32, I should have mentioned that.
    Can you use them when you point directly to them..

    > C:\Windows\System32\ping.exe 127.0.0.1

    ? If so, you probably have a messed up PATH variable.

    > echo %PATH%

    Should have "C:\Windows\System32" in it, does it?
  • edited Oct 2005
    hello.. got also similar problems, but to almost all of my command except dir and echo.

    here is the result of \echo %PATH%
    C:\Documents and Settings\farid>echo %PATH%
    C:\Program Files\Microsoft Visual Studio\Common\Tools;C:\Program Files\Microsoft Visual Studio\Common\Msdev98\BIN;C:\Program Files\Microsoft Visual Studio\DF98\BIN;C:\Program Files\Microsoft VisualStudio\VC98\BIN;C:\Program Files\Bonjour\;C:\Program Files\QuickTime\QTSystem\

    how to fix this problem

    thanks
    hiku
  • Park_7677Park_7677 Missouri Member
    edited Oct 2005
    hiku said:
    hello.. got also similar problems, but to almost all of my command except dir and echo.

    here is the result of \echo %PATH%
    C:\Documents and Settings\farid>echo %PATH%
    C:\Program Files\Microsoft Visual Studio\Common\Tools;C:\Program Files\Microsoft Visual Studio\Common\Msdev98\BIN;C:\Program Files\Microsoft Visual Studio\DF98\BIN;C:\Program Files\Microsoft VisualStudio\VC98\BIN;C:\Program Files\Bonjour\;C:\Program Files\QuickTime\QTSystem\

    how to fix this problem

    thanks
    hiku
    You're missing some key entries. What OS are you running?
  • Park_7677Park_7677 Missouri Member
    edited Oct 2005
    For Windows XP:

    Right click "My Computer" and click "Properties". Click the "Advanced" tab up top followed by the "Environment Variables" button at the bottom. In the 2nd list box, scroll down to the 5th or 6th entry "Path", select it and click "Edit". Add "%SystemRoot%\system32;%SystemRoot%;" (minus the quotes) to the beginning of the line. Okay the changes and try out your commands now.

    Windows 2000 is similar. If you have a different OS, post what it is and we can figure it out.
  • edited Oct 2005
    Hello....
    thanks Park,.. mine is XP, actually after long searching I could fixed it, similar with your suggestion.

    regards,
    farid
  • edited Apr 2007
    Park_7677 said:
    For Windows XP:

    Right click "My Computer" and click "Properties". Click the "Advanced" tab up top followed by the "Environment Variables" button at the bottom. In the 2nd list box, scroll down to the 5th or 6th entry "Path", select it and click "Edit". Add "%SystemRoot%\system32;%SystemRoot%;" (minus the quotes) to the beginning of the line. Okay the changes and try out your commands now.

    Windows 2000 is similar. If you have a different OS, post what it is and we can figure it out.



    GR8 fix mate!

    well done
  • edited May 2007
    Park_7677 said:
    For Windows XP:

    Right click "My Computer" and click "Properties". Click the "Advanced" tab up top followed by the "Environment Variables" button at the bottom. In the 2nd list box, scroll down to the 5th or 6th entry "Path", select it and click "Edit". Add "%SystemRoot%\system32;%SystemRoot%;" (minus the quotes) to the beginning of the line. Okay the changes and try out your commands now.

    Windows 2000 is similar. If you have a different OS, post what it is and we can figure it out.
    hey i know this is an ancient thread,but thanks alot man,,,was driving me nuts,,,what could have caused this?it happened on both of my laptops.....perhaps a new software program i installed?and is this just the tip of the iceberg?do i have other issues about to unfold?
  • ThraxThrax Professional Shill, Pokémaster, Watch Slut Toronto, ON Icrontian
    edited May 2007
    Usually it's a piece of software installed that adds a env. variable. Decently common, but some crappy software mucks it up.
  • edited May 2007
    Thrax said:
    Usually it's a piece of software installed that adds a env. variable. Decently common, but some crappy software mucks it up.
    so,not to worry about any kind of rootkit or virus attacking my pc?lol i've run every scan and seem free of any virus/spyware etc.was just setting up a static ip,and when i typed ipconfig/all i had same issues as above ppl......the thing i did to just fix it,will stay fixed?or upon running whatever software caused the issue in the first place,will make it screwed again?
  • ThraxThrax Professional Shill, Pokémaster, Watch Slut Toronto, ON Icrontian
    edited May 2007
    It'll stay fixed unless you reinstall whatever problematic software triggered it.
  • edited May 2007
  • edited Aug 2008
    I'm having the same issue listed here regarding the ping and ipconfig command but ALSO cannot open gpedit.msc. I get an error that MMC could not create the snap in. I checked my path. IT does have system32 in the path. Path displays as follows:

    %systemroot%\system32;%systemroot%;%systemroot%\system32\wbem;C:\Program files\ect ect ect

    Park_7677 said:
    For Windows XP:

    Right click "My Computer" and click "Properties". Click the "Advanced" tab up top followed by the "Environment Variables" button at the bottom. In the 2nd list box, scroll down to the 5th or 6th entry "Path", select it and click "Edit". Add "%SystemRoot%\system32;%SystemRoot%;" (minus the quotes) to the beginning of the line. Okay the changes and try out your commands now.

    Windows 2000 is similar. If you have a different OS, post what it is and we can figure it out.
  • edited Feb 2009
    Hello ,

    I have a similar problem but its my windows 2k3 enterprise server with Service pack2, i could find the ping.exe file in system32.for me even telnet is not recognised
  • edited Feb 2009
    I understand this is an old thread but can someone help me.
  • hi. how about for windows 7? please.
    thanks
  • TushonTushon I'm scared, Coach Dallas Icrontian
    For Windows 7:

    Right click "My Computer" and click "Properties". Click the "Advanced System Settings" link on the left followed by the "Environment Variables" button at the bottom. In the first box, select PATH and click "Edit". Add "%SystemRoot%\system32;%SystemRoot%;" (minus the quotes) to the beginning of the line. Okay the changes and try out your commands now.
    Edited to fit
Sign In or Register to comment.