If geeks love it, we’re on it

Howdy, Stranger!

You found the friendliest gaming & tech geeks around. Say hello!

Triple boot your MacBook Pro



  • edited Jul 2008
    fortillian wrote:
    So I followed your directions explicitly. My only problem is that if i select to boot ubuntu, refit fades and i see the penquin and then nothing happens. It doesnt boot linux. I have the same setup as you. Macbook Pro 15" 2.5ghz. Vista-64bit Ultimate and Ubuntu 8.04. Windows Vista runs great, and OS X runs the same. Where did i go wrong?
    on rEFIt Partitioning tool i see

    Current GPT Partition Table
    # Start LBA End LBA Type
    1 40 409639 EFI System (FAT)
    2 409640 465715239 Mac OS X HFS+
    3 465977384 524571133 Basic Data
    4 524571134 620936368 Basic Data
    5 620936369 625142414 Linux Swap

    Current MBR partition table:
    #A Start LBA End LBA Type
    1 1 409639 EE EFI Protective
    2 409640 465715239 AF Mac OS X HFS+
    3 465977384 524571133 07 NTFS/HPFS
    4 524571134 620936368 83 Linux

    Status: Tables are synchronized, no need to sync.

    Any ideas why linux wont start up?

    Well, my first thought is to tell you to turn the machine off and try again; every time I loaded a new OS I had to choose it, then it would get stuck at the faded icon, then I'd hard reboot and it would be fine.

    Other than that I'm not sure what to tell you. I only modified the instructions for XP, and I haven't used them with Vista at all, so I wouldn't even know the first place to look.

    Good luck!
  • edited Jul 2008
    Let me start by saying thank you for this post and all the helpfull information. After 7 attempts I have my tripple boot Mac running great.

    These are the items that hung me up and what steps I changed a bit to resolve them. I only had trouble with the Linux install and the windows MBR getting corrupted.

    First: On my Macbook the hotkey to get to a command line / Terminal was "FN+CTRL+ALT (OPTION)+F2"

    Second: I am new to Linux so I did not know to use "sudo" in front of the command line for backing up and replacing the mbr so I changed

    dd if=/dev/sda of=/tmp/sda.mbr bs=512 count=1

    to "sudo dd if=/dev/sda of=/tmp/sda.mbr bs=512 count=1"

    Third: The replacement of the MBR part did not work for me to apply at any point before Grub ran its part of the process. I am not sure if the original poster did this from command line or if something was different but the Grub bootloader pops up almost immediately after the Partitioner.

    As an additional note to select where Grub puts the bootloader you need to select Advanced Options on the final install screen immediately after inputting your name and password.

    So for the windows bootloader to not be corrupted I had to restore the MBR at the very end of the installation when the installation asks for a restart. It is at that point that I ran the command again using sudo,

    "sudo dd if=/tmp/sda.mbr of=/dev/sda"

    And my last note is that it is "FN+CTRL+ALT (OPTION)+F7" to exit back to the installation.

    Thanks again for the post and I am enjoying my tripple boot Macbook!
  • SnarkasmSnarkasm Madison, WI Icrontian
    edited Jul 2008
    I think the part people are routinely missing is the fact that he used the alternate install CD, not the standard desktop install; when installing via the alternate install, the process installs the OS files first, and then later asks where you want to install GRUB rather than how the desktop CD just sets everything up first, asks for partitioning info, and then just assumes GRUB will go where it wants it to go. Did you use the alternate install disc?

    Either way, thanks for the extra info and glad to hear you got it up and running!
  • edited Jul 2008

    Thanks for pointing that out. I did not use the alternate install CD. Sounds like that could have been the cause for some confusion on my side. I appreciate your help. Guess my tips can be applied if someone uses the standard install.
  • the_technocratthe_technocrat IC-MotY1 Indy Icrontian
    edited Jul 2008
    Yes, I intentionally listed the Alternate Install DC in the directions because of its install procedure. Using a different method of Ubuntu installation will require changing the install procedure.
  • edited Jun 2010
    I know this topic is old, but it still has useful information, so I thought I'd post a quick update with my recent dealings.

    I went back to a triple-boot today (finally got a bigger hard drive in the laptop). Have OSX, Win7 Ultimate 64-bit and Ubuntu 10.04 32-bit. Partitioned the drive first with Apple's bootcamp utility (GPartEd doesn't like HFS+ resizing), then used GPartEd to cut it up into what I wanted (NTFS, ext4, swap). Installed Win7, then tried Ubuntu, and ran into problems....I did everything like the guide said, except I could not get Ubuntu to boot (detected in rEFIt as legacy OS because it doesn't recognize grub2), but even after waiting and rebooting and waiting it didn't work. So I reinstalled, this time with the desktop live CD (used the alternate CD the first time) and followed tedrios's instructions for using the desktop disc, and it worked! So, IDK if it was something I botched, something different with 10.04 or what, but the desktop CD worked better for me.

    The "dd" commands are still definitely necessary, though. But, in the end, it all works! :)

    So, there's a quick update for newer OS's.

  • SnarkasmSnarkasm Madison, WI Icrontian
    edited Jun 2010
    The desktop install CD is definitely loads better than it used to be - even I switched off of the alternate installer for 10.04. Congrats on a sweet triple boot - Win7, OSX, and Ubuntu all in one machine is a very nice powerhouse.

    Any reason you went with 32-bit Ubuntu over x64? Just wondering.
  • edited Jun 2010
    Snarkasm wrote:
    The desktop install CD is definitely loads better than it used to be - even I switched off of the alternate installer for 10.04. Congrats on a sweet triple boot - Win7, OSX, and Ubuntu all in one machine is a very nice powerhouse.

    Any reason you went with 32-bit Ubuntu over x64? Just wondering.

    I've had issues with software compatibility in x64 Ubuntu in the past...Granted, I haven't tried it in a long time (a couple of years, I think) so I don't know how much has been fixed, but stuff like Flash never worked (and probably a couple other things too), and this was before the Broadcom STA driver was included in the Restricted Devices and you had to use ndiswrapper and the Broadcom driver for bootcamp to get wifi working, which didn't work in x64 when I tried it last.

    I could probably give it a try again, actually, especially with the wifi driver...That was my biggest issue haha. Are you using it, Snarkasm? Is it pretty good?
  • SnarkasmSnarkasm Madison, WI Icrontian
    edited Jun 2010
    Yessir. Everything worked - out of the box - on a 10.04 x64 install. I was floored, but it has really improved. Flash is perfectly fine. I use Chromium over Firefox, and I couldn't be happier right now. I'm really happy with the changes.
  • edited Jun 2010
    That's impressive! Wow. I'm downloading the 64-bit ISO now to make a bootable USB stick from (the optical drive in the MBP is a LITTLE slow haha). I'll let you know how it goes, thanks for the info!
  • SnarkasmSnarkasm Madison, WI Icrontian
    edited Jun 2010
    Worth a laugh: if you try to install using the alternate install disc via USB, the installation will get stuck in a circular loop because it can't find your CD. Kind of amusing.

    But yeah - got around that by the miracle of the desktop installer working for my hardware for the first time. I was impressed. :)

    Good luck! Let us know if you run into troubles.
  • edited Jun 2010
    Finally got 10.04 64-bit up and running! For whatever reason rEFIt didn't like my bootable USB device (and I tried doing it a couple of different ways, but it kept booting Linux from my hard drive haha), so I just used the LiveCD again. Got it installed and immediately ran into wifi problems (apparently WPA support is buggy), but got that fixed with this post, and then ran into issues with sound but that got fixed by editing /etc/modprobe.d/alsa-base.conf and adding this to the bottom of the file:
    options snd-hda-intel model=mb5
    and setting my hardware to the Analog Stereo Output profile in Sound Preferences.

    The last thing I did was change my UID by creating another administrator-user, logging into THAT account, changing my real account's UID to the UID of the user on my OSX install with
    sudo usermod -u <osx id=""> <ubuntu username="">[OSX UID] [Ubuntu username]
    then logging back into my real account, and deleting the temp account. This allowed me to access all of my files and directories in my OSX partition with full access, so I can do stuff like set up Rythmbox to watch my iTunes folder for any music so I can listen without duplicating my entire library :cool: (this also required installing pysdm (Storage Device Manager) to get the Mac partition to mount at log-in instead of me manually editing the fstab file; much easier!)

    Oh, and rEFIt was updated March 7th to auto-detect grub2, so Ubuntu is now recognized as Linux instead of "Legacy OS".

    I am back to a super triple-boot! :D
  • SnarkasmSnarkasm Madison, WI Icrontian
    edited Jun 2010
    Rock on, bud. Keep up the good work. :D
  • Options
    edited Aug 2010
    Hi, I've followed your guide and now I've the three installed on my macbook pro. But I think there's something that is worth noting: after installing Linux, I just could boot Mac OS X, and with Linux and Win, rEFIt freezed. But after doing a complete shutdown, it worked as supposed.
    Thanks man!
  • Options
    edited Oct 2010
    Any word on whether or not triple boot can be achieved with a MacBook 1,1 in this manner?
  • Options
    bootcamp is giving me trouble partitioning the disk...it freezes everytime i try to do it. can i use disk utility to partition the disk?
Sign In or Register to comment.