If geeks love it, we’re on it

Howdy, Stranger!

You found the friendliest gaming & tech geeks around. Say hello!

Icrontic Expo 2014: The gaming & general geekery event you don't want to miss. Read about what's new this year and then buy tickets here.

Problem with .xls & .xlsx Office 2007 in Windows 7 OS

joanmtjoanmt Dallas, TX New
edited Feb 2012 in Technology
I had to get a new computer & re-install everything. When I re-installed by Microsoft office 2007 Enterprise edition and then go to My documents, the files show as the correct file extension. I have un-installed and re-installed Office 2 times. The program first defaulted to Adobe reader, so I un-installed Adobe thinking it might force it the make Excel work correctly. It did not & then defaulted to my ACDSEE picture program.
When I try click on the file & try to change the program that it opens with, excel is not even listed. Where can I go and what can I do?????

Thanks in advance! :)

Comments

  • ThraxThrax Professional Shill, Pokémaster, Watch Slut Austin, TX Icrontian
    Hold shift and right click the file, then select "open with." Choose excel.
  • joanmtjoanmt Dallas, TX New
    Hi Thrax, that is part of my problem, Excel is not listed as the recommended program nor is it in the area of other programs either. The program is on the computer. Help????
  • ThraxThrax Professional Shill, Pokémaster, Watch Slut Austin, TX Icrontian
    Hit the browse button and track down excel.exe. It's probably in C:\Program Files (x86)\Office\Office14 or the other program files folder.
  • TushonTushon I'm scared, Coach Dallas Icrontian
    http://support.microsoft.com/kb/2464297 tells you how to repair install Office to restore file extension associations. Alternatively,

    Control Panel > Default Programs > Associate a file type or protocol with a specific program > Find each file type and change it to whichever Office program is appropriate.

    Repair install with restoring associations will be faster
  • joanmtjoanmt Dallas, TX New
    I am not finding it when I do a search on the computer. The program was installed off an external HD not off discs inserted into the DVD drive. If I find it on the external HD can I just copy it onto this computer and then run the .exe file? Thanks!
  • ThraxThrax Professional Shill, Pokémaster, Watch Slut Austin, TX Icrontian
    I'm not sure what you mean, but I think it's just easiest to respond with this: reinstall Office on your PC, not on an external hard drive. It doesn't matter how you install it (from a DVD or a file on a hard drive), as long as it gets installed to the hard disk in your PC.
  • TushonTushon I'm scared, Coach Dallas Icrontian
    Yes, the office install itself needs to be pointed to C: ... and you should be clear about what you are not finding.
  • joanmtjoanmt Dallas, TX New
    Ok, Should I remove Office 2007 from the PC 1st (from add/remove programs)? My install source is an external HD that holds the Office 2007 program. I have done this before & never had an issues, that is why I am so baffled now. I attach the external HD to my PC via a USB Cable, find the application on the external HD & double click on the setup icon to install it on to the PC. It goes through the process of the install & tells me it is complete. The Software is Microsoft Office Enterprise 2007. I am installing all aspects of the program.
  • TushonTushon I'm scared, Coach Dallas Icrontian
    So, if you follow the instructions from my post, what are you missing?
  • joanmtjoanmt Dallas, TX New
    When I do this: (Control Panel > Default Programs > Associate a file type or protocol with a specific program > Find each file type and change it to whichever Office program is appropriate) on the .xlsx files-Description is MS Excel Worksheet-Current Default-MS Excel, on the .xls files-Description is XLS File-Current Default is ACDSEE (was Adobe Reader until I uninstalled it). When you click at the top to change the program, the recommended program is ACDSEE, when you click on the drop down for other programs, MS Excel is not listed as an option to change it to.

    On my other Windows 7 computer that I did the same process to, the .xls files-Description is-Microsoft Excel 97-2003 Worksheet-Current Default is Microsoft Excel.

    Please advise.... Thanks! :)
  • TushonTushon I'm scared, Coach Dallas Icrontian
    So ... follow the instructions for repairing your install of office?
  • joanmtjoanmt Dallas, TX New
    Hi again, I installed all necessary update for the computer first. I performed the repair, nothing. I have even installed Microsoft Office Excel 2003 and still the same issue. Should I just uninstall the Office 2007 and re-install it?
  • Create a new user account, login with that and test opening a spreadsheet. If it grabs the excel program right and opens up without issue. You can continue along building up your profile there.
    If not, then yes, the trouble is with office directly, and that should be looked into.
  • joanmtjoanmt Dallas, TX New
    This is the funny part of this whole thing. If I open Excel 2007 & then select open and go to my files and click on one of the .xls files, it will open with no problem. It is just the file association issue. This makes it difficult to manage because when I go to My Documents, I cannot open them there directly because it opens with the program that it has defaulted to, which currently is ACDSEE. When I go to try to change it to associate with another program, the only other recommended program is Adobe Reader. Even though I have installed a stand alone copy of the Excel 2003, that program is still not available from the drop down area of other programs in that file association area. If I take one of those .xls files, open it in excel by going to the open option in the program itself, then save it as a .xlsx file, it will save it correctly and allow me to open it directly from My Documents. Here is the problem. Not everyone has Office 2007 on their computers and if I tried to send it to someone who cannot open that file extension. Then it is an issue. I will try to create an additional user to see if that is the problem, but I think it is a problem with the software recognition.
  • ThraxThrax Professional Shill, Pokémaster, Watch Slut Austin, TX Icrontian
    When I go to try to change it to associate with another program, the only other recommended program is Adobe Reader.
    Hit the browse button and track down excel.exe. It's probably in C:\Program Files (x86)\Office\Office14 or the other program files folder.
  • joanmtjoanmt Dallas, TX New
    Yes, I have found the excel.exe file in Office 12 file
  • CrazyJoeCrazyJoe Winter Springs, FL Icrontian
    Then select that as the program to associate .xls and .xlsx files and it should work.
  • joanmtjoanmt Dallas, TX New
    This may sound stupid, but where do I do that at?
  • ThraxThrax Professional Shill, Pokémaster, Watch Slut Austin, TX Icrontian
    See attached image.
    open.png
    1023 x 1094 - 217K
  • joanmtjoanmt Dallas, TX New
    Ok, thank you for the image, when I go there and get to the Office 12 file, double click on it to open it, then there is another folder, 1033 and I double click to open it and it is empty.
  • ThraxThrax Professional Shill, Pokémaster, Watch Slut Austin, TX Icrontian
    Excel.exe should be in the Office12 folder. If it's not there, then Office is installed somewhere else on your PC, or not installed at all.
  • joanmtjoanmt Dallas, TX New
    It is under the (x86) program files not just the regular program files, so how do I get to those x86 files on the browse when trying to select the right program to set as the default, like you showed me in the picture?
  • joanmtjoanmt Dallas, TX New
    OMG!!! Right after I sent the last post to you, all of the sudden the x86 files appeared! I don't know what happened, but I was able to select Excel & it worked! :) All is good now! I appreciate all of your help along with the other guys that put in time here too.... I love this site, you guys are all so wonderful!!!! :clap:
  • ThraxThrax Professional Shill, Pokémaster, Watch Slut Austin, TX Icrontian
    Glad everything worked out for you. :)
  • joanmtjoanmt Dallas, TX New
    You guys rock!!!!!!! :)
Sign In or Register to comment.