Any LINUX users wanna help me out please....

TrumandrummerTrumandrummer Taylor Michigan
edited February 2008 in Science & Tech
So Im trying to broaden my range with operating system usage and im currently in a Linux network administrator class at school...

I decided to install Red Hat Fedora core 8 on my lappy on a new partition...

The partition, install, and dual boot were all successful, and everything works except for the internet...

I can not, for the life of me, get Linux to work with my lap tops wireless card....

can anyone please help me out?
thanks a lot

EDIT: I boot into Linux, log in. Go to system>administration>network then when the network configuration tool thing loads I go to new>wireless network>select wireless device> but there is nothing to select, just empty.......... so its not even recognizing my card
«1

Comments

  • jhenryjhenry California's Wine Country
    edited January 2008
    What kind of wireless card do you have right now? Check in Windows' Hardware Manager.

    Ubuntu is the only distro I've had that works right out of the box on my laptop (AR5001X+)

    You'll probably need to download a module that includes the driver.
  • SnarkasmSnarkasm Madison, WI
    edited January 2008
    If I had to guess, you have a Broadcom card, and they're a b|tch and a half to get working correctly. You're probably going to need ndiswrapper and the driver for your specific card, so we can't really do anything until you find out what card you have.

    If you open a terminal and enter "lspci" without the quotes, somewhere in that list you should see something like
    03:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)

    With Ubuntu, you can use the Restricted Drivers manager and the new bcm43xx has had a lot of work put into it, so it works pretty well across all Broadcom chipsets, but if you want to stick with RH and you have a Broadcom, ndiswrapper will become your friend. It's a hard problem to tackle, but I guess there's not really a better way to really learn Linux right off the bat.

    Let us know what you have and we can help you more.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited January 2008
    yes it is a Broadcom card:D

    how do I use ndiswrapper?


    Thanks a lot for helping


    EDIT: I would switch to Ubuntu, like you mentioned but...... Im usng RH because thats what we will be using in my class
  • jhenryjhenry California's Wine Country
    edited January 2008
    Okay, get us the exact model number. lspci like MJ said will get you it.

    Then, go to here and find your card:

    http://ndiswrapper.sourceforge.net/joomla/index.php?/component/option,com_openwiki/Itemid,33/id,list_b/

    If it's there, you're in luck.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited January 2008
    And if there isn't? :(

    I didn't see my exact one in the list, a couple were pretty similar :(

    heres my model number

    Broadcom corporation BCM94311MCG wlan mini-PCI (rev01)
  • SnarkasmSnarkasm Madison, WI
    edited January 2008
    Broadcom 4311 is your model. These links might be of interest:

    http://ndiswrapper.sourceforge.net/joomla/index.php?/component/option,com_fireboard/Itemid,27/func,view/catid,3/id,330/
    http://ubuntuforums.org/archive/index.php/t-640890.html

    Even if they're for ubuntu, the steps will likely be of use to you. Other than that, just start googling "ndiswrapper BCM94311MCG" and snoop around.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited January 2008
    I can't seem to install ndiswrapper, i downloaded it, put it on a flash drive, booted into Linux, then opened the file and........

    wow, confusing is all I can say...

    there is a bunch of files and I don't know where to start...
  • SnarkasmSnarkasm Madison, WI
    edited January 2008
    Are you following the ndis wiki? It has an installation help page.
  • Your-Amish-DaddyYour-Amish-Daddy The heart of Texas
    edited January 2008
    If you have an install.sh file, you can su and drop that into a terminal window and it'll install it for you.

    Alot of packages for FC can be obtained with yum, and installed the same way. Put your lappy on the 10/100 and see if it'll work like that, then just use yum to get everything you need. ndiswrapper should be in yum. Treat it like apt.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited January 2008
    Ok, well I followed the tutorials and they didn't seem to be working, and since they were all for Ubuntu I decided to just go ahead and install Ubuntu instead, it cant be THAT much different from Fedora, I know they both come with different apps and stuff......

    So I downloaded Ubuntu off their site, and burnt the image, just like I did with Fedora.

    Restarted my computer with the disc in, The Ubuntu menu came up and I clicked "Install or start"...

    It showed the Ubuntu loading screen, then went to a black screen where it loaded a bunch of white lines with [ok] next to them (just like Fedora did)

    Then the screen gos black and never loads, I tried it about 10 times, with 2 different disks,

    any ideas?
  • SnarkasmSnarkasm Madison, WI
    edited January 2008
    Yes. Is this a laptop?

    If it is, you have a couple of different options; first thing you can do when it gets to the [start or install] screen, is look for the "more options" choice or whatever (F6, I think?), and at the end, add "noapic noacpi nolapic noirqpoll" and boot with those options and see if it loads correctly. If those don't work, another option is to download the "alternate install disc" that has a text-based installer that doesn't rely on a graphics environment to install, and then you can see if you need different graphics drivers or if some different tags will let you boot.

    Hope this helps. If you can post your specs and laptop model information, we can narrow down what actually need to be done and what extra steps you might need for full functionality.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited January 2008
    Yea, its a laptop

    its an Hp pavilion dv9008nr
    1gb of ram
    amd turion64 x2
    nvidia go (not sure the specifics, ill have to look up)
    120gb hdd

    I tried what you said ("noapic noacpi nolapic noirqpoll") and it didn't work, but then I remembered what we did in class the other day was "acpi=off" and I tried and it worked,

    so now its installed, and im gonna try working on the network problem...

    Also when I go to turn the visual effects on it says "Enable Nvidia accelerated graphics driver" and I click "enable" and then it comes up with the error "the software source for the package nvidia-glx-new is not enabled"

    could this be, because im gonna need internet connection for this?

    EDIT: ok, im a little confused, in the tutorial to fix my networking card or w/e it tells me to...

    Add bcm43xx to the /etc/modprobe.d/blacklist file
    by typing.....

    sudo vim /etc/modprobe.d/blacklist
    add this line “blacklist bcm43xx” (without “”)

    I did this and was able to add the line, but I have no clue how to save it ??
  • Straight_ManStraight_Man Geeky, in my own way Naples, FL
    edited January 2008
    Yes, the source for that package is probably on the internet.
  • SnarkasmSnarkasm Madison, WI
    edited January 2008
    You can replace vim with nano and edit it the same way, and the controls for nano are listed on the bottom of the window. Nano's easier if you're new, so try it that way.

    Also, you might not need ndiswrapper if you use ubuntu and the restricted drivers manager, are you sure you need to? Try getting it to work normally first. Use an ethernet connection for the time being, too.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited January 2008
    well I messed around with the network settings for a few minutes, its a little different than fedora, but I can't seem to get the wireless working,

    and my desktop computer with the router, is in the basement and my laptop is in my room, which is upstairs and on the other side of the house. It would be a B**** to run an Ethernet cable that far, not to mention I would probably have to drill a hole in my floor. Although I do have a 100 foot cable not in use.....
  • SnarkasmSnarkasm Madison, WI
    edited January 2008
    This is why, when working with networking, you test right next to the router so if you're not getting wireless to work, you know it's a software problem. :D Then you don't even have to worry about ethernet cable lengths! Just use a short one. How about that.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited January 2008
    That is a very good point lol:D

    Well today, I decided just to run the Ethernet wire, and save the hassle of the wireless card.

    All I had to do was run the cable all the way across my basement (in the drop Ceiling) and then drill a hole in my floor send the cord up, then drill a hole in the back of my desk. lol

    but the good news is, im actually on Ubuntu right now, typing this. So the internet now works.

    I have one more question and then I THINK ill leave you all alone lol:wink: .....
    about the visual effects.... I searched for nvidia-glx-new and found a lot..... so much I was very confused, I downloaded 2 packages but they wouldn't install....

    I would love it if someone could help me with this:D , my graphics card is Nvidia Geforce go 6150

    Thanks a lot for helping :cool:
  • JBJB Carlsbad, CA
    edited January 2008
    https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

    Hmm, the support list has the 6150, sans the "Go". I'm not sure if it will work with the Go version since it seems to call out other supported Go drivers.
  • SnarkasmSnarkasm Madison, WI
    edited January 2008
    Yeah, you should just be able to enable restricted drivers (and in fact, it should have prompted you for this when you started up the first time, IIRC) and it'll figure out what you've got and go get the drivers for you.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited January 2008
    well it does let me choose to enable, and when I do, it loads for a second then says

    "the software source for the package
    nvidia-glx-new
    is not enabld"
  • SnarkasmSnarkasm Madison, WI
    edited January 2008
    And?
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    thats all it would say, then it made me close..

    but, I searched and searched and kept finding post for people with the same problem, 1 out of like 15 posts about this error actually had the solution.

    but im pretty sure that I got it, I was able to install nvidia-glx-new and then re-run the visual effects, click enable.... and it asked for a reboot, so im about to go do that.
  • SnarkasmSnarkasm Madison, WI
    edited February 2008
    Sweet. Good luck!
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    somehow, i knew something would go wrong.

    Ok I restarted, only to see an error message telling me "my screen and graphics card could not be detected properly, your computer is running in low graphics mode"

    everything was very large, so i went into the settings and was able to make the resolution a little better, but its not nearly how it was

    im guessing this means I need drivers for my specific card?
  • SnarkasmSnarkasm Madison, WI
    edited February 2008
    You might want to reconfigure the xserver. Log into a tty prompt (ctrl-alt-F1) using your regular login credentials, and run "sudo dpkg-reconfigure xserver-xorg" and run through that and see if it helps.
  • wthwwwthww Terre Haute, Indiana
    edited February 2008
    This particular wifi Card BCM94311MCG is not supported by the ndis nor bcm43xx modules, or else I'd have Debian loaded on my lappy. ;)
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    reconfiguring the x server did not work

    I went through the set up and it got to this point asking if i had 24bit (32bit) color... and when i hit ok it says "overwrite settings, backup ........ something something"

    And it didn't change anything, upon restart a window pops up saying
    "running in low graphics mode .... " and my resolution is still very messed up
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    I finally figured it out and I need just a little help please..........

    I found an nvidia driver for linux that works for nvidia go 6150,
    I also found a tutorial on installing it
    I did ctrl-alt-f1
    then sudo /etc/init.d/gdm stop (to turn off x server)
    then sh NVIDIA-Linux-x86-1.0-9629-pkg1.run
    then it started trying to install, gave me the agreement, i accepted, then it said that it needs to compile a kernel for me.... but then it comes up with an error saying "PLEASE INSTALL YOUR DISTRIBUTION'S libc development package"

    now in the tutorial it says "you probably need to install your kernels development/source code stuff"

    but it doesn't explain how to at all,

    can anyone help me install my distributions libc development package? because I have no clue where to start
  • SnarkasmSnarkasm Madison, WI
    edited February 2008
    Doing a quick Google search myself, have you tried ENVY? Lot of people saying it's the only thing that worked and worked flawlessly.

    More in the line of answering your question, I'd imagine it's looking for the linux-header and linux-header-dev packages, but checking my synaptic, there's a bunch of options there, so I can't necessarily pick out one or two that you for sure need. I'd head into apt or synaptic and check out linux-header*.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    well im pretty bummed out right now...

    I actually successfully installed the drivers manually. I had to install the Linux headers like you said

    But it still is running in low graphics mode and the resolution is messed up. I tried configuring the xserver again and It fixes nothing, it goes right back to how it was, as if it ignores my xserver changes.

    And then I tried Envy, which took a while to install. I kept getting an error on edpendencies or something... but I was able to finally get it installed, ran it....
    installed the NVIDIA drivers that way, and it was successful..

    I restarted and, the f'n error message came up still, telling me im in low graphics mode.

    I found out my resolution, so I have it set to look better, but if I restart, it resets itself

    and the visual effects don't work because when I enable them it requires a restart, and when I restart............ Well you know what happens

    Im stumped :rolleyes::sad2:
Sign In or Register to comment.