Windows 7 upgrade keeps encountering an error...?

TrumandrummerTrumandrummer Taylor Michigan
edited November 2009 in Science & Tech
I finally got my upgrade disc from asus.
I am currently running windows vista home premium 64bit, and my copy of windows 7 is also home premium 64bit.

I run through the upgrade process, it copies temporary files, starts the set up. Then it starts checking for compatibility, and it fails every time.

The first time it failed, it told me that I had to uninstall a program. So I did. But now, it fails every time and the only thing it says is

"An error prevented a required compliance check from completing. Cancel the installation and try upgrading again"

I have tried the upgrade numerous times. I tried restarting and doing the upgrade again. Unfortunately, a full install is not really an option for me. I am dual booting Linux and Vista, and I don't really want to have to back up two operating systems.

Does anybody know what might be causing this error?

Thanks in advance


  • TrumandrummerTrumandrummer Taylor Michigan
    edited November 2009
    Screw it.
    No matter what...... Upgrade or clean install, it will still probably mess up my bootloader. It shouldn't overwrite the Linux partition though. So I think I am just gonna back up all of my important stuff from vista, and perform a "clean" install. After that hopefully I can recover my GRUB bootloader.

Sign In or Register to comment.