GPU Folding killing my PPD

edited February 2010 in Folding@Home
Having problems with my GPU folding on my newly upgraded rig. My PhenomII X4 is folding like a champ. HFM.NET estimates PPD output between 3k and 5k for the SMP client. The estimate seems a bit on the high side but still, for the sake of this problem we will assume it's precise if not accurate. I set up GPU folding for my HD5770, any time I have both SMP and GPU going at the same time though, my estimated PPD for the SMP client drops to around 500-1k range, the GPU estimate is around 2.5K. Is this a known issue when folding on the HD5000 series? Anyone know of a workaround to keep the GPU client from killing my SMP clients performance?

Comments

  • TimTim Southwest PA
    edited February 2010
    Maybe setting the flags in environment variables will control CPU usage? I did it in my new dual GPU install, and I'm able to have 2 GPUs going plus one CPU / SMP instance on my dual core E7300 and I'm still using only 80%-90% of the CPU. See the details towards the end of my topic in this forum on adding an extra GPU.
  • edited February 2010
    I was seeing something similar with my i7 running SMP2 and my 5850 running GPU2. I played with environment variables and got CPU usage down ~3% for GPU2 but it still cut my SMP2 production by almost 40%.

    Hooray.
  • _k_k P-Town, Texas
    edited February 2010
    That is the one bad thing about SMP2 GPU2 is apparently killing the ppd with some WUs.
  • edited February 2010
    I'm not complaining too much as SMP2 pulls in more PPD than SMP1 + GPU2 combined.
  • GargGarg Purveyor of Lincoln Nightmares
    edited February 2010
    I was running GPU2 on my 5770 before I started running SMP2, and I noticed that SMP was killing my GPU PPD.
    I reduced the priority on the SMP client and knocked it back to 75% usage, and now I'm making more PPD with both clients together than I would with just the GPU. But not by much. It might be a bigger difference if I was running a quad.

    This was after I had already tweaked environment variables for the GPU2 client. The CPU usage is 2-8%, and it was still interacting with the SMP client poorly.
  • edited February 2010
    Hmm... at least it's not just me having the problem. I've been running SMP2 only for the past 3 days. Looks like my total production is averaging around 5k ppd now. The 2 days I had SMP2 and GPU2 going I netted around 3k ppd. Looks like I'll stick to just SMP2 folding for now. Thanks guys.
Sign In or Register to comment.