Fix wmplayer.exe always running on Windows 7

ThraxThrax 🐌Austin, TX Icrontian
edited January 2012 in Science & Tech
Windows 7 users of all flavors have probably noticed that wmplayer.exe, better known as Windows Media Player, is always running in the background, consuming up to 30MB of RAM.

To disable this useless process, attempt the following fix:

-Open Windows Explorer.
-*PASTE* the following address into the address bar and hit enter: Control Panel\All Control Panel Items\Windows SideShow
-Untick any of the Windows Media Player check boxes.
-Upon closing the window, wmplayer.exe will be disabled permanently.
NOTE: This fix will not compromise your ability to run Windows Media Player manually!

If that does not resolve the issue, follow the processes outlined in these guides:

The Arcter Journal: How I Fixed My wmplayer.exe Always Running on Vista Issues
My Note Book On The Web: My wmplayer.exe Always Running in the Background


  • AnnesAnnes Tripped Up by Libidos and Hubris Alexandria, VA Icrontian
    edited August 2010
    I have so little use for Windows Media Player that I usually just uninstall it completely. But I'll definitely reconsider reinstalling and doing this. Thanks!
  • This works, Thrax. Thank you. This would cause my Logitech G15 play/pause to also play/pause the last movie I watched, even if it was closed, which is super irritating when you're playing a video game that can't survive an alt-tab (Skyrim).
Sign In or Register to comment.