Radeon not running full speed

GargGarg Purveyor of Lincoln Nightmares
edited December 2010 in Folding@Home
I just got my new 5770 folding on my work rig (second one in my sig), and it first, everything was fine. Only problem was it was using up too much CPU, so I changed some environment variables.

FLUSH_INTERVAL = 128
BROOK_YIELD = 2
CAL_PRE_FLUSH = 1
CAL_NO_FLUSH = 1

Worked great - that reduced CPU usage from 20% to 9%, and my SMP PPD increased dramatically. Since the GPU client finished that WU, however, it hasn't kicked my GPU into the higher clocks it should be using. I'm still getting 100% GPU usage, but at 400mhz, instead of the 860 it should be running. I tried increasing the FLUSH_INTERVAL to 256, but no dice.

attachment.php?attachmentid=28698&stc=1&d=1291419798

halp?

Comments

  • GargGarg Purveyor of Lincoln Nightmares
    edited December 2010
    I just got back on my work rig, and it looks like only that one WU folded at half speed.

    TPF went back to normal in the log after it completed that one, and GPU-Z says it's running at full speed, now.

    Weird.
  • TushonTushon I'm scared, Coach Alexandria, VA
    edited December 2010
    Strange. You might check in the CCC if there are "sleep" settings and disable them. Also, you can turn of Aero to increase folding performance.
  • GargGarg Purveyor of Lincoln Nightmares
    edited December 2010
    It's doing it again. Not even FurMark kicks up the frequency.

    So weird! Couldn't find any sleep settings in CCC (but good luck finding anything in that GUI).

    Possibly a BIOS setting? I'm stumped.
  • ThraxThrax Professional Shill, Watch Slut, Mumble Hivemind Drone Austin, TX
    edited December 2010
    There are no sleep settings in the GUI. You might check your Windows power profile.
  • GargGarg Purveyor of Lincoln Nightmares
    edited December 2010
    You wouldn't believe what was causing the problem. Apparently, 400/900 is a specific clock setting used while playing video. I had a YouTube window open. As soon as I closed it, it jumped up to full speed. Derp.
  • TushonTushon I'm scared, Coach Alexandria, VA
    edited December 2010
    lololol derp. That's silly!
  • ThraxThrax Professional Shill, Watch Slut, Mumble Hivemind Drone Austin, TX
    edited December 2010
    I forwarded this to the driver team to see if it's a known issue.
  • TushonTushon I'm scared, Coach Alexandria, VA
    edited December 2010
    A man ... on the inside.
  • GargGarg Purveyor of Lincoln Nightmares
    edited December 2010
    Thrax wrote:
    I forwarded this to the driver team to see if it's a known issue.

    Gracias! I'm sure my particular situation isn't of much concern (regarding the impact on Folding performance), but if somebody had a YouTube window open when they started a game, that seems like a bug worth fixing.

    I've replicated the issue on my home computer, which happens to have the same Sapphire Vapor-X 5770. In the screenshot below, you can see the GPU clock initially running at 880 MHz from running F@H GPU (which is a slight OC over the card's default 860). It dipped to 400 after I open the hotness on the left.

    attachment.php?attachmentid=28704&stc=1&d=1291684445
  • primesuspectprimesuspect Beepin n' Boopin Detroit, MI
    edited December 2010
    Clearly the card couldn't handle Nataly Dawn's hotness
Sign In or Register to comment.