Need help troubleshooting wifi

BlackHawkBlackHawk Bible music connoisseurThere's no place like 127.0.0.1
edited December 2013 in Hardware
I'm trying to see if the WiFi USB dongle on my desktop is flaking out on me. The thing is that there is now way to connect directly to the router. There's an HTPC sitting right next to the router connected via WiFi as well (I'm lazy) and it's showing the full 50mbps download on Comcast's speed test. The desktop is only hitting half that download speed which is also reflected in my slow Usenet downloads. Is there a way I can internally test the wifi connection with a nice UI or something. Maybe an app that can test transfers between the HTPC and the desktop?

Here's more info. This may have been occurring for awhile now and I've just noticed it. The desktop holds all my media and the HTPC plays it on the TV. Occasionally the HTPC has started buffering when playing SD media. I would power cycle everything and it would clear up. I don't know if that's related.

The network specs are an Asus RT-N66U with the latest firmware. Desktop is running Windows 8 and has a Linksys/Cisco AE2500 WiFi adapter. The HTPC is a Foxconn nt-A3700 with built in 802.11b/g/n running Windows 7.

Just in case, I tried downloading Ubuntu to rule out Usenet and it was also downloading at half speed. I also tried transferring a large movie from the desktop to the HTPC and it's also going at the same speed as the speed tests.

Comments

  • BlackHawkBlackHawk Bible music connoisseur There's no place like 127.0.0.1
    I'm starting to think it's a specific problem between the wifi adapter and the router.

    Test while tethered to my phone:
    image

    Back with the router:
    image

    HTPC with router (through VNC because I'm lazy):
    image
  • BlackHawkBlackHawk Bible music connoisseur There's no place like 127.0.0.1
    And I'm a noob. Forgot to check at what speed the wifi adapter was actually connecting at and I noticed that it was sitting at 39Mbps even though I haven't altered any settings from before. I don't think it's interference since my network is the only one that my wifi card picks up. Maybe it's just dying?
  • BlackHawkBlackHawk Bible music connoisseur There's no place like 127.0.0.1
    And the problem comes to a close. Sorry for making the post. I fixed it by checking Asus' support forums and someone wrote that the best firmware for the router was two versions back, I downloaded it and my speeds are back to normal. I guess I needed to work through it aloud.

    In case anyone finds this thread along their journeys, the firmware I used was version 3.0.0.4.276 from their download section.
    PinkTiberiusLazarusprimesuspect
  • PinkPink Colour Sweden
    Glad you got it resolved, in retrospect I wish I had read it from bottom to top instead and realized you had solved it hehehe!
  • csimoncsimon Acadiana
    edited December 2013
    I would have picked up that router this weekend at BBY but it was overpriced as compared to online by $20. Glad you got your issue sorted BlackHawk.
  • SnarkasmSnarkasm Madison, WI
    Such a good forumer, leaving info and LINKS about solving the issue! Good on you.
    primesuspect
  • shwaipshwaip bluffin' with my muffin
    If you see similar problems, you should also check to make sure that there aren't a whole bunch of wireless devices on the same channel. This causes major problems in my current house.
Sign In or Register to comment.