Some Far Cry 4 map browser custom maps won't launch

adarryladarryl No Man Stands So Tall As When He Stoops To Help a Child. Icrontian
edited August 2015 in Gaming

My wife and I both play FC4 custom maps found in the map browser. She is on her Intel-based PC with a Gigabyte GTX 970 while my PC is AMD-based with an MSI GTX 970. I can load and play all of the custom maps (new outpost/top rated outpost/assault/extraction/etc. while she can load and play maybe half or more of the same. Her map downloads appear to work like they're supposed to until the map itself launches to game play then she either gets a black screen she has to kill through task mgr. or windows throws up a pop-up saying far cry 4 .exe has stopped working and must be closed. I can find no help on this anywhere. We have the same amount of RAM (8 Gb) though hers is DDR3 while mine is DDR2. Both are Kingston HyperX. Her CPU is a Sandy Bridge i5 2500K while mine is an X4-965 Phenom II. Both machines are Win 10 though this difference in play-ability was present when they were both Win 7. I can play a custom map on my PC and she can then try to launch the same map on hers and it crashes. If it crashes once, it will always crash on her PC even when tried days later. This is most frustrating and I am no help to her in resolving the issue; I have tried all I can think of to no avail. I have checked temps and even done a line by line comparison of game play settings with nothing different noted. She has no other performance problems with her PC in any application or any other game, only FC4's custom maps. Does anyone out there have any idea what we should try to resolve this? Many thanks if you do. This is frustrating the hell out of too, cause I am along for the disappointing ride.

P.S. Far Cry 4, in general, has not liked updated geforce drivers on her PC. Presently, she is running version 353 okay for everything including the main game. I am running the 355 driver.


  • TushonTushon I'm scared, Coach Alexandria, VA Icrontian

    I would try verifying game files, clean install of latest drivers, and possibly some hardware checks like RAM and videocard (I would use Memtest86+ from UBCD or similar multi-use tools and Furmark, respectively).

  • adarryladarryl No Man Stands So Tall As When He Stoops To Help a Child. Icrontian

    Thanks for the input, Tushon. Memtest came back clean, no errors. On the other hand, verifying game files came back with corrupt files, but when I select fix errors, I get an active internet connection not found. Of course, this is nuts because there is a verified active connection. Uplay was doing this same thing last night but after a while, it started working again. I will try again later.

  • adarryladarryl No Man Stands So Tall As When He Stoops To Help a Child. Icrontian

    Eureka! The verification of game files appears to have done the trick. She's playing a custom map right now that crashed FC4 on her PC last night and looking forward to trying others that crashed previously. Beers on me, Tushon!

  • TushonTushon I'm scared, Coach Alexandria, VA Icrontian


Sign In or Register to comment.