Any LINUX users wanna help me out please....

2»

Comments

  • SnarkasmSnarkasm Madison, WI
    edited February 2008
    Hmm. At this point, I might, if it's an option to you, completely reinstall and try Envy straight from the start. This'll give you a clean start again and will prevent conflicts or other things that might have been caused from trying a bunch of different things. If it still doesn't work out, let us know and I'll look around a little more for you.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    you mean complete reinstall of Ubuntu right?

    And in that case, if I have and AMD 64, do you think I should run Linux 64bit?
  • SnarkasmSnarkasm Madison, WI
    edited February 2008
    I would! And I do. It's solid. But yeah, a full reinstall. Delete the partition and everything, leave nothing behind.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    alright, well its 2:20 am here, so im gonna set up the install, get some sleep and get back at it in the morning

    I was teaching my mostly-blind grandma how to use outlook express most of the day, talk about a frustrating day lmao

    thanks for all the help
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    ERRORS after ERRORS after ERRORS

    I Installed 64bit Ubuntu, installed drivers trough envy, restarted and everything was SERIOUSLY messed up. I was getting faded colors on my screen and it kept getting darker, and I couldn't see anything.

    So I deleted the partition started over this time with 32bit... installed drivers through envy, restarted.... same thing, seriously messed up :sad2:

    So I installed 64 bit, and decided to install the drivers for 64bit manually before doing anything, And the first step is to do "su" and it prompts for a password, I entered my password and it keeps giving me errors, it worked perfectly fine before, but it wont work now....

    "su: authentication error"
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    well I did sudo -i to get past that last error ^^^
  • SnarkasmSnarkasm Madison, WI
    edited February 2008
    Keep plugging away. I'm watching the thread, I'll chime in if I can think of anything that'll help. Hard to do over the web, though, unfortunately. Keep the faith.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    ok quick question....

    In this tutorial, the person isn't doing this on Ubuntu (although people have had success on ubuntu)

    And after installing the drivers it tells me to do the following steps...

    1. sax2 -r -m 0=nvidia
    2. cp /var/lib/sax/xorg.conf /home/yourusername/Desktop/xorg.conf
    open up that file, and look for the line that says
    driver "nv"
    and change it to
    driver "nvidia"




    My problem is, in step 1. it says sax2 is not a command
    and in step 2. I dont even have a sax directory in /var/lib/

    Any clues on what to do here?


    ALSO: I have a feeling that im on the right track though, because after the drivers installation, I didn't get the low graphics mode error (knock on wood) lol
  • ThraxThrax Professional Shill, Watch Slut, Mumble Hivemind Drone Austin, TX
    edited February 2008
    That's because SAX is suse's xserv configuration utility, which Ubuntu would not have.

    Try running sudo dpkg-reconfigure xserver-xorg instead.
  • SnarkasmSnarkasm Madison, WI
    edited February 2008
    and then after that, "sudo nano /etc/X11/xorg.conf" and look for that "driver nv" line, it'll be down a ways. Change that to nvidia and see what's what.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    well It was already set to nvidia
    I THINK things are looking good
  • SnarkasmSnarkasm Madison, WI
    edited February 2008
    Huzzah! Good luck, let us know what happens.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    ughhh

    restarted, and got the low graphics mode again :(
    When I logged in I got a message saying "NEW restricted drivers are in use..... "
    I couldn't read the rest before it went away:sad2:

    EDIT: also, when I go to system>administration>screen and graphics...
    it has my monitor set for 800x600 and my graphics to some vesa card...
    and I rechecked the xorg and it still says nvidia
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    im completely stumped....
  • SnarkasmSnarkasm Madison, WI
    edited February 2008
    Ok, this is kind of weird, actually.

    It appears I have the Go 6150 too, and I've never had these problems. A section of my xorg.conf is here:

    Section "Device"
    Identifier "nVidia Corporation C51 [Geforce 6150 Go]"
    Driver "nvidia"
    Busid "PCI:0:5:0"
    Option "AddARGBVisuals" "True"
    Option "AddARGBGLXVisuals" "True"
    Option "NoLogo" "True"
    EndSection


    And I'll post my full xorg.conf in a codebox here for your reference.
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    #Section "InputDevice"
    #	Identifier	"Configured Mouse"
    #	Driver		"mouse"
    #	Option		"CorePointer"
    #	Option		"Device"	"/dev/input/mice"
    #	Option		"Protocol"	"ImPS/2"
    #	Option		"ZAxisMapping"	"4 5"
    #	Option		"Emulate3Buttons"	"true"
    #EndSection
    
    Section "InputDevice"
    	Identifier	"Synaptics Touchpad"
    	Driver		"synaptics"
    	Option		"SendCoreEvents"	"true"
    	Option		"Device"	"/dev/psaux"
    	Option		"Protocol"	"auto-dev"
    	Option		"HorizEdgeScroll"	"0"
    	Option 		"HorizScrollDelta" 	"0"
    	Option 		"MinSpeed" 	"0.15"
    	Option 		"MaxSpeed" 	"0.25"
    	Option 		"AccelFactor" 	"0.00"
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"stylus"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"stylus"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"eraser"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"eraser"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"cursor"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"cursor"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "Device"
    	Identifier	"nVidia Corporation C51 [Geforce 6150 Go]"
    	Driver		"nvidia"
    	Busid		"PCI:0:5:0"
    	Option		"AddARGBVisuals"	"True"
    	Option		"AddARGBGLXVisuals"	"True"
    	Option		"NoLogo"	"True"
    EndSection
    
    Section "Monitor"
    	Identifier	"Generic Monitor"
    	Option		"DPMS"
    	Horizsync	28-64
    	Vertrefresh	43-60
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"nVidia Corporation C51 [Geforce 6150 Go]"
    	Monitor		"Generic Monitor"
    	Defaultdepth	24
    	SubSection "Display"
    		Modes		"1280x800"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
     	screen 		"Default Screen"
    	Inputdevice	"Generic Keyboard"
    	Inputdevice	"Synaptics Touchpad"
    	
    	# Uncomment if you have a wacom tablet
    	#	InputDevice     "stylus"	"SendCoreEvents"
    	#	InputDevice     "cursor"	"SendCoreEvents"
    	#	InputDevice     "eraser"	"SendCoreEvents"
    	Inputdevice	"Synaptics Touchpad"
    EndSection
    Section "Module"
    	Load		"glx"
    	Load		"synaptics"
    EndSection
    

    Hope that gives you some good reference. That was almost exclusively written by the restricted drivers manager, though. Post yours up and we'll see what looks different, if you like.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    Im not so sure what happened, but I think my xorg.config got deleted.........

    I did "sudo nano /etc/x11/xorg.conf and it showed the file correctly, then I went to copy it all and I couldn't..

    So I closed terminal and re-opened it, typed "sudo nano /etc/x11/xorg.conf again, but this time its blank and says "new file" at the bottom :scratch:
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    Well I just browsed to /etc/x11/xorg.conf and was able to view it correctly
    Here it is...............
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc104"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"		"/dev/input/mice"
    	Option		"Protocol"		"ImPS/2"
    	Option		"ZAxisMapping"		"4 5"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Synaptics Touchpad"
    	Driver		"synaptics"
    	Option		"SendCoreEvents"	"true"
    	Option		"Device"		"/dev/psaux"
    	Option		"Protocol"		"auto-dev"
    	Option		"HorizEdgeScroll"	"0"
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"stylus"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"stylus"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"eraser"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"eraser"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"cursor"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"cursor"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "Device"
    	Identifier	"nVidia Corporation C51 [Geforce 6150 Go]"
    	Driver		"nvidia"
    	BusID		"PCI:0:5:0"
    	Option		"UseFBDev"		"true"
    EndSection
    
    Section "Monitor"
    	Identifier	"Generic Monitor"
    	Option		"DPMS"
    	HorizSync	30-70
    	VertRefresh	50-160
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"nVidia Corporation C51 [Geforce 6150 Go]"
    	Monitor		"Generic Monitor"
    	DefaultDepth	24
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Generic Keyboard"
    	InputDevice	"Configured Mouse"
    
    # Uncomment if you have a wacom tablet
    #	InputDevice     "stylus"	"SendCoreEvents"
    #	InputDevice     "cursor"	"SendCoreEvents"
    #	InputDevice     "eraser"	"SendCoreEvents"
    	InputDevice	"Synaptics Touchpad"
    EndSection
    
  • JBJB Carlsbad, CA
    edited February 2008
    You need a display section of your screen. See MJ's post.
  • SnarkasmSnarkasm Madison, WI
    edited February 2008
    That's what I'd say, too. Throw in a subsection Display like you see in mine and see what you get.
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    Its as if the system wants to pick its own settings....

    I added the subsection with my resolution (1440x900) and restarted, and guess what? low graphics mode with a super low resolution

    I went System>Administration>Screens and Graphics and set the resolution to widescreen 1440x900 then I went to graphics and it knew that I had NVIDIA Geforce 6 series, but the driver was set to vesa. I changed that to, clicked ok, It said I had to log out for changes to take effect, so I logged out and guess what? low graphics mode, super low resolution again :sad2:
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    Ehh this is annoying the crap out of me,

    im having so much fun with Linux at school, I got beryl and tons of effects installed, then I come home to this....
    all screwed up,

    I think im gonna try Fedora again, Something has to work, it just doesn't make sense. It was such an easy install at school, and my lap top is more powerful than those.

    Its just the stupid support issues lol
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    I seen that Fedora core 9 ALPHA is out,

    Im thinking ill try that and see if maybe since its newer it will have added support for some newer hardware devices.
  • SnarkasmSnarkasm Madison, WI
    edited February 2008
    If you're talking about the Go 6150, I don't exactly think that's "new", though I guess I could be wrong. Either way, good luck, and I hope it works out. To be honest, Beryl's a tiiiiiiiiny bit overrated, but it is neat, and I imagine I'd be healthily frustrated if it didn't work. Screen resolution is my kryptonite, though. First thing I do on any install of any OS is make my screen res correct... except in Windows, because most of the time I need my chipset drivers to get my internet functional so I can go retrieve my graphics drivers. :D
  • TrumandrummerTrumandrummer Taylor Michigan
    edited February 2008
    well yea, searching around about beryl, I found that out...

    But for my first time using it, it was pretty cool.

    And I really want to use Linux, but I CANNOT use any OS with a messed up res.. It aggravates me so much, lmao

    I hate when I go over a friends and their f'n tool bar and icons are huge and stretched. :bigggrin:
  • drasnordrasnor Starship Operator Hawthorne, CA
    edited February 2008
    If you still have Ubuntu installed, let's try this:
    Open a terminal and run:
    sudo lsmod | grep nvidia
    This will tell us if your graphics card driver is loaded. If you don't get a match, run:
    sudo dmesg | grep -i nvidia
    This will tell us if the computer attempted to load the driver. If either of these fail, reinstall the nvidia binary driver.

    Post your /var/log/Xorg.0.log as an attachment as well.

    -drasnor :fold:
Sign In or Register to comment.