Installing Folding F@H as a service on Vista

scottscott Medina, Ohio
edited July 2009 in Folding@Home
Well it took a little bit of head scratching but I figured it out.

first trick was running the executible in compatability mode.

And the biggie was installing the service as administrator. It seems the admin account is disabled by default, even in safe mode. The trick is turning on the administrator account.
From the "RUN" box type secpol.msc
go to Local Policies / Security Options The first item here is admin account ... Enable it !

then log into the administrator account and install F@H from there. Viola'




Scott


On a side note I am running this on my NF7 with a mobile barton @2400 and only 512mb ram with a 9800 pro vid card. It seems to run just fine.

Comments

  • Sledgehammer70Sledgehammer70 California
    edited September 2006
    Sweet, Good find Scott.
  • profdlpprofdlp The Holy City Of Westlake, Ohio
    edited September 2006
    This is the first reference I've found anywhere on how to do this.

    Well done, Scott! :respect:
  • scottscott Medina, Ohio
    edited September 2006
    I am sure that admin account is disabled by default as a security measure.
    It would probably be a good idea to disable it again after installing the service.

    I just kind of stumbled through the discovery. When trying to install the service the console said somthing like "You don't have administrator access" So I tried to log in as admin in safe mode and it said " The account has been disabled" So I did some snorting around in the MS knowledge base and found the secpol.msc command.

    Even a blind squirrel finds an acorn once in a while.



    Scott
  • edited September 2006
    Nice work, Scott!
  • fatcatfatcat Mizzou
    edited September 2006
    just the info i needed...thank you:thumbsup:
  • primesuspectprimesuspect Beepin n' Boopin Detroit, MI
    edited September 2006
    Perfect! Folding away in vista on both CPUs now. Thanks a ton, scott! :D
  • LeonardoLeonardo Wake up and smell the glaciers Eagle River, Alaska
    edited September 2006
    Scott, you're gonna be famous!

    Dont' know about 'famous', but well done, nonetheless. You may very well be a pioneer in this aspect of Folding.
  • QCHQCH Ancient Guru Chicago Area - USA
    edited September 2006
    Thanks Scott!!!! :thumbsup:
  • jaredjared College Station, TX
    edited October 2006
    alright gurus what did I do wrong.

    I enabled the administrator, logged off my user, logged onto admin, ran the no-nonsense client exe, told it to start up as a service.

    however when i reboot into my normal user nothing starts up, then I tried reinstalling it under my typical user account, still doesn't start up at boot.

    what do i need to do to get this sucker running as a service in the background?

    cheers :fold:
  • LeonardoLeonardo Wake up and smell the glaciers Eagle River, Alaska
    edited October 2006
    Jared, I can't answer your question specifically, but can tell you a workaround. Just manually put the client .exe shortcuts in the "All Users" startup file. Then, whatever user account starts the computer will also start the folding clients. If you then want the Folding Windows to be minimized to the task tray, use TrayIt.
  • scottscott Medina, Ohio
    edited October 2006
    Jared

    Just double checking here. Forgive me if you knew this.

    The no nonsense console installs as a service and won't be "Visible". You have to check in task manager to see if it is running. If you installed it in 2 locations it may be running twice.

    Scott
  • jaredjared College Station, TX
    edited October 2006
    no its ok, yeah the process doesn't start up in the task manager... as far as i can tell it never installed the service at all

    what i did
    - enabled admin
    - logged off jared into admin
    - ran the console client
    - told it to install service
    - waited for install to finish
    - rebooted pc
    - logged on to normal jared account
    - no service running :(

    maybe i misread the first post?
  • scottscott Medina, Ohio
    edited October 2006
    Did you check to see if it is a service ?

    Right click "my computer" / Manage /services/ and see if it is in the list. if it is double click it and see if it is set to automatic or manual. If it is not there then you were correct that it did not install.

    see first screen shot in first post

    Check and let us know


    Scott
  • edited July 2009
    scott wrote:
    Well it took a little bit of head scratching but I figured it out.

    first trick was running the executible in compatability mode.

    And the biggie was installing the service as administrator. It seems the admin account is disabled by default, even in safe mode. The trick is turning on the administrator account.
    From the "RUN" box type secpol.msc
    go to Local Policies / Security Options The first item here is admin account ... Enable it !

    then log into the administrator account and install F@H from there. Viola'


    Although this is an old thread, it's still the first Google hit for the a few search strings for this topic and apparently, it does not work for Vista Home (or at least OEM versions of Vista Home) for lack of secpol.msc. I suggest the following, which should take less than two minutes:

    1. Right click on the folding@home .exe file and select 'create shortcut'.
    2. Right click on the shortcut and select 'properties'.
    3. Append ' -configonly' (excluding quotes, including space) to the contents of the 'target' field, leaving the original contents of that field otherwise unaltered.
    4. Click 'OK'
    5. Right click on the shortcut and select 'Run as administrator'.
    6. Select 'run' and then 'allow', when prompted. You now have the ability to enable F@H as a service.
  • lordbeanlordbean Ontario, Canada
    edited July 2009
    To my knowledge, the amount of hoop-jumping required really isn't as big as all that. All I have to do is launch the folding@home executable, make sure I configure advanced options, and then when it asks "Start automatically, install as a service in this directory:" I just type "y". The program will still start in normal mode, but all you have to do is close it and then reboot, and voila. It's a service.
  • edited July 2009
    Well, yeah, that's part of the process, but unless you jump the hoops outlined above, then when you type 'y' and hit return, an error comes back, saying that the program does not have the permissions required to perform the task that it tries to perform.
  • lordbeanlordbean Ontario, Canada
    edited July 2009
    There must be a difference in the way I have my vista configured then. Most likely the fact that I have UAC disabled, because I hate it.

    Anyhow, running things as admin is generally a good idea anyway, when it's likely to make a system configuration change.
Sign In or Register to comment.