Get Starcraft working on Windows 7: Three easy steps

13

Comments

  • edited May 2010
    Dude!!! This totally works, I don't know why & can't imagine how y'all figured that one out but thanks anywho. :)
  • edited June 2010
    thanks.. this really works.. easy steps..
  • edited June 2010
    LOL THIS WORKS. i'd say ONLY let the window open, no need to check all those things. :S:S it's strange really ... works same for AoEII ... can't believe it ... if this is a bug i hope it won't get fixed ! lol :P
  • edited June 2010
    windows 7 is shit it will not play any of the games on or off microsoft list if they do install they go back to the desktop again and again and before you ask yes i have more then what it take to play all of the games out there windows 7 was made out in left field and was not made for any of the computers out there new or old so you like to play a game get windows xp home or pro that will fix it microsoft lied again and again
  • mertesnmertesn I am Bobby Miller Yukon, OK
    edited June 2010
    ttx19 wrote:
    windows 7 is shit it will not play any of the games on or off microsoft list if they do install they go back to the desktop again and again and before you ask yes i have more then what it take to play all of the games out there windows 7 was made out in left field and was not made for any of the computers out there new or old so you like to play a game get windows xp home or pro that will fix it microsoft lied again and again
    One person's badly stated opinion versus everyone else on this forum who have had no problems running games on Windows 7 since the first beta release last year... You're doing it wrong.
  • primesuspectprimesuspect Beepin n' Boopin Detroit, MI
    edited June 2010
    he mad
  • edited June 2010
    Sweet! Thanks a lot guys. Fixed it right up. :)
  • edited July 2010
    Step 1 and Step 2 is not required.
  • edited July 2010
    Yeah fine fine...My colours works fine but...i dont have sound in starcraft (only background music) i tried everything .CTRL + S not help me...Settings in SC and in computer are good.i have windows 7 (32 bit)
  • edited July 2010
    @ raas: ha ha, yeah your right with out any type of intermediary program like wine that you'd,.. have,.. to. oh yeah you gotta down load install n configure that. that is easier. yay linux.
  • edited July 2010
    coulda been a graphics burp. colors on screen look like your lookin through a heat sensitive camera? reinstall graphics card drivers or make sure its seated properly. usually fixes that quick, i ran it on my system win7 64 with no issue other than resolution wasn't supported so the picture was a bit streched.
  • edited July 2010
    i have a new fix.

    open taskemanger.
    than kill explorer.exe.
    than start a new task (starcraft.exe)
    and starcraft will start witheout any problems.
    when your finisht playing open taskemaneger and create a new task ( explorere.exe ) (c/windows/explorere.exe) and there is your taksebar back.


    this works for me ( using windows 7 Ultimate 32bit )
  • edited July 2010
    thank you very much. my starcraft experience was almost ruined. you saved me.
  • edited July 2010
    I am beginning to believe it is the Windows 7 Desktop background setting set to "Change picture every 30 minutes" that caused Starcraft to lock on me. Once I changed that I no longer needed to leave the screen resolution window open.
  • edited July 2010
    hey guys I've tried most of these solutions and they wont work for me (besides installing a second OS on a partitioned drive i find that a wast of room and time) when i launch SC my main monitor screen goes black and even if i alt tab it stays black i need to unplug the power socket in order to get a picture even wile the game is minimized and I've tried this wile in-game for SC still now picture wondering if any1 has any ideas on this?

    I'm ruining:
    Catalystâ„¢ Version 10.7
    ATI Radeon HD 4870x2 2gig card
    Q6600 quad core processor 2.4ghz
    6gig ram 800mhz
    Windows 7 64bit home premium
    HP HDMI Monitor

    i also have my monitor connected to me graphics card via a HDMI cable and got my LG 42inch LED LCD TV connected via HDMI cable also. I'm also running Display Fusion pro v3.1.10

    can any1 help me please i would really like to get SC running as i want to pass the missions on it b4 doing the missions on SC2 plus i got my girlfriend into it so she would also like to play the 1st game before starting the second lol
  • edited July 2010
    Ive also tried compatible mode in XP and i still get the black screen were i need to unplug and then replug the power cord to get it to work again
  • edited July 2010
    This works...until I finish a level, then I get an error message. "Couldn't read 0x004bdb81 referenced at 0x00000001." or something like that. Any fix for this?
  • edited July 2010
    I recently changed my windows 7 home edition to windows 7 ultimate 64 bits. Prior this OS change i could run starcraft but i had the colour issue, after checking on tons of forums for a fix i got to a file wich was refered a couple post back, the file made a reg edit wich fixed the issue, avaible for both 32 and 64 bits windows 7 versions.
    I used Starcraft with its 1.16.1 version and after fixing the colour issue i never had a problem with it.
    After i changed to windows 7 ultimate 64 bits i managed to fix the colour issue with the same files, though now whenever i want to start playing it first asks me to insert the cd... (wich i have "mounted" using daemon tools) after re mounting the images i seem to be asked anyway for them, but the game runs anyway... NOW if i click on the multiplayer icon and pick any normal starcraft or brood war exp. the game crashes... theres nothing there to click upon, the screen goes black and all i can see is the white mouse arrow. not to mention i have to reboot in order to use my laptop. ah im using a Samsung R480.
    hope you guys can help me out cause right now im considering on installing a 2nd OS on the pc just cause i really enjoy playing old games. Regards!
  • edited August 2010
    this link provides a registry fix

    http://go.hopx.net/2010/05/256-color-issues-with-directdraw-and.html

    for starcraft v 116
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\DirectDraw\Compatibility\StarCraft116]
    "Name"="Starcraft.EXE"
    "ID"=hex:ca,89,65,49
    "Flags"=hex:00,08,00,00

    worked like a charm
  • edited August 2010
    U Guys are geniuses!! The fix worked great, thanx ALOT!
  • edited August 2010
    I second making a batch file, works flawlessly. For those who don't know how, make a new text (.txt) file and copy and paste:

    TASKKILL /F /IM "explorer.exe"
    cd C:\"Program Files (x86)"\Starcraft
    start /w C:\"Program Files (x86)"\Starcraft\Starcraft.exe
    start C:\Windows\explorer.exe

    then save it and rename the extension to .bat

    This is for mine running on windows 7 64bit, if you aren't running 64 then your program file folder name will be different. Same fix also works for MOO2
  • edited August 2010
    Also the above fix is really easy because you only have to do it once, then you can just double click the icon and it starts up no hassle.
  • edited August 2010
    jorg's fix is the best, thanks! And the explanation on the website (link above) makes total sense, no need for disabling explorer or changing any compatibility settings once applied.

    Thanks again jorg!
  • edited September 2010
    I thought the patch messed up the game but apparently it was Windows fault! Thanks a lot for the tip.
  • edited September 2010
    @primesuspect

    Ignore these shitheads, I actually do have a Dual boot on which I run Starcraft II, however its nice to be able to just batter Stacraft up in 7 and fool about.

    The workaround works perfectly and all I have to do is open the settings,. I'll take that any day over the rest of the LInux, ball kicking, wine shite. Gret workaround man, thanks.
  • edited September 2010
    I followed your step 1 & 2, but the solarizing didn't go away for me until I downloaded the latest patch from Blizzard and followed the instructions on how to play StarCraft without the CD. Then it worked perfectly.
  • edited October 2010
    YES! SOMETHING FINALLY WORKED! Thanks Jeff!
  • edited October 2010
    Wow, you blew all the other complex solutions (that didn't work) right out of the water. Thank you for this.
  • edited October 2010
    God bless you i downloaded 20 programs and non of them fixed it and yours did. A++++++++++++++++++
  • edited November 2010
    personally, as far as the color issue goes. The way I get all or many of the older games to work. old school trick in my day was just add the *ddraw.dll* to the main game directory. "NO .bats, NO reg tweaks, NO compatibility issues... at that time Fallout 1 from Interplay was the most common used ddraw.dll file for it's day..

    1. copy ddraw.dll into main game directory
    2. run under admin

    If memory serves me correctly.. that same fallout file also worked on Warcraft 1-3 and Freelancer or any directx 5.1-8.2 beta series games for a color fix

    common dates used 1987 - 2008 88KB ddraw.dll
This discussion has been closed.