Get Starcraft working on Windows 7: Three easy steps

24

Comments

  • ThraxThrax Professional Shill, Watch Slut, Mumble Hivemind Drone Austin, TX
    edited September 2009
    (Why 32-bit?)
  • LincLinc Bard Detroit
    edited September 2009
    (It's what Brian handed me from E3 - I'm lazy)
  • edited September 2009
    Starcraft started going buggy for me (same symptoms-whacked pixel depth making everything looked "solarized" in xp. Happened after I installed a desktop manager (in my case, stardock's fences). And from rare search hits, it seems like this is a pretty common for Starcraft to have issues with desktop managers so I'm betting that it has to do with win7 desktop management in general or aero in particular. But the fault seems to lie in Starcraft and the way it expects to interface with it's environment (old game can't be blamed) but hopefully blizzard will address in future patch (bless them, they're still supporting the game).
  • rolleggrollrolleggroll Next to a bowl of rice
    edited September 2009
    Reading this article inspired me to re-install Starcraft. Followed the article. Starcraft works. I join a game. Lost Temple. A few minutes later, Reavers are in my base tearing me a new one as I can't micro lings for shit to defend myself. I remembered why I stopped playing.

    Good article though.
  • edited October 2009
    Thats because you played lost temple. You can always play money maps or UMS and you wont face such stiff competition. Also it usually helps to check your opponent's record, try to play someone with a record similar to your own.

    Usually i'll host a game and won't start it until i've successfully been able to /stat the other player and am happy with the opponent. I boot out anyone with a 'new' record (0-0) or obscenely bad (1-50-1) or obscenely good (120-10-0) records.
  • edited November 2009
    it's amazing - it works! thanx m8 :D
  • SpampySpampy Madison, WI
    edited November 2009
    Discovered this myself a couple of weeks ago getting the game to work in Win7 x64 for my roommate, good to see the fix spread!
  • edited December 2009
    make a batch file that looks like this:
    "taskkill /f /IM explorer.exe
    cd "C:\Program Files\StarCraft\"
    Starcraft.exe
    start explorer.exe "
    and it will work for you! tested on windows 7 - home edition - legal version ;)
  • edited December 2009
    Alternatively, you CAN run Starcraft, and "any" XP compatible program, in XP Mode. Simply click Tools -> "Disable Integration Features" and Starcraft will work fully. Integration requires a 16 bit color scheme and the resolution changes depending on the size of the Virtual PC window. Disabling the integration features allows you change any settings you want. HOWEVER, it also disables the ability to shortcut to the program from Win7 as well as other things.
  • edited January 2010
    Hey I just got Windows 7 yesterday, and I tried your fix but it didnt work. crossalchemist, I was reading your comments, maybe you could help me out? I know how to make a batchfile I open notepad, but what do i put inside it? and what do i save it as, and where do i then put that batch file? please help me I really want to play StarCraft, so far i'm dissapointed in windows7. I never had problems like this in vista. Also this happens for antoer game I play Need For Speed Most wanted, any idea how to fix that as well?
  • edited January 2010
    crossalchemist I did get it working with that method, but the host resolution does not adjust to the VPC guest resolution. The game plays in a tiny little window on my 28-inch monitor. Unplayable.
  • edited January 2010
    Just tested on win7 32bit,all u need to check under compatibility tab for starcraft are the first 2 check boxes (256 color mode and 640x480) and the last one (run as administrator).You can leave anything else unchecked and you dont need to run screen resolution and leave it open.
    Hope this helps.
  • edited January 2010
    Does not work for me (yet).
    Using win7 pro 32-Bit version. Weird thing is
    - I first installed the game
    - checked 256 color mode and adjusted color depth to 16 bit (via right click desktop etc.)
    - Game was running excellent - without any problems.

    Next I updated the game to 1.61 >> that's were all the problems started - I have tourqoise screen mess ups and stuff and nothing seems to help - any solutions?
  • edited January 2010
    I'm running Window 7 (6.1.7600) on an Alienware Aurora (i7 920). I had the exact issue the author described. I used his suggestion to correct the problem - thank you. The only thing I wanted to add was that I didn't need to leave the "System Resolution" window open.

    Thanks a ton guys! Starcraft fans world wide thank you!
  • Radio91PRadio91P Layton, UT
    edited January 2010
    Thanks for the article prime.....you know what else....good article prime.

    Glad the peanut gallery could join us too!
  • edited February 2010
    Thanks Jonathan for the batch script it works like a charm =)
  • edited February 2010
    I'm a little confused as to how installing a different OS on a separate partition or creating a VM install is easier than Lincoln's three steps. I'd rather complete three easy steps than install an entire extra OS just to play a game.
  • JengoJengo Pasco, WA | USA
    edited February 2010
    I agree with GHoosdum.

    thanks lincoln/prime! 3 step guide worked perfect!
  • edited February 2010
    checking all the boxes and keeping the screen resolution window opened worked. Checking the frist two boxes and run as administartor box worked. Didn't try the batch file though, since the later fix worked really well. Thanks for all who posted such cool fixes.
  • edited February 2010
    My Fix:
    Just disable visual themes under the compatability tab. That was all I had to do. I did NOT need to check the other ones.

    My system:
    Win7 Pro 64-bit.
  • edited February 2010
    NEVERMIND! Nothing is fixing it. Apparently that was only temporary...
  • edited March 2010
    Thanks - works fine for me. Amazing that someone actually figured this out!
  • edited March 2010
    Thanks man..it works!!on win 7 ultimate 32bit :D
  • edited March 2010
    see, this fukcin starcraft won't work, i try to update on b.net and it immediately says, reinstall or i may have a virus or some BS. what a joke, god damn blizzard and there terrible support why do they have to make hte best games :(
  • edited March 2010
    Bought Starcraft Battle Chest, CD set. It installed version 1.15.2 and runs just fine on my Windows 7 64 bit system, no tweaks required. Nvidia driver 196.21.
  • edited April 2010
    Thanks it worked with my friend's windows7 64 bit
  • QCHQCH Ancient Guru Chicago Area - USA
    edited April 2010
    Awesome news that so many folks are able to play Starcraft on Win7. :rockon:
  • edited May 2010
    Didn't work for me!
    I was using it on WXP and it worked well, but when I tried on W7 the colours were all messed up and this solution didn't work for me.
    Any Ideas?
    I'm running it with Alcohol 120%
  • edited May 2010
    This is a ridiculous and absolutely stupid way to fix an issue that has been already solved by MS and Blizz a while ago. The only problem is they did not update their fix for version 1.16. Ok look, download this .rar containing registry keys: (link removed, safety cannot be verified -mod)

    It'll contain an x64 key for those using 64-bit win7 and an x86 key for those running 32-bit win7. Double click the registry key that is marked for your version of win7. Say yes and it'll update your SC with the already existing fix.

    Credit goes to Warlord_7 from forums.battle.net
  • primesuspectprimesuspect Beepin n' Boopin Detroit, MI
    edited May 2010
    "ridiculous" and "absolutely stupid" in that it has helped thousands of people before the fix existed.

    Idiot.
This discussion has been closed.